Import Problem


I've got commerce kickstart running on a BOA hosting platform (self hosted). I have set up my product types and am trying to import them using feeds and the commerce product processor. I am able to sucessfully import the products into the database, but they do not show up in the list of products. I can see them in the database, but I cannot see them in the list of products.

I have included a screenshot of the database and a screenshot of the commerce product screen. Can anyone help me out here?

Image icon screenshot.png128.23 KB
Image icon screenshot2.png86.55 KB
Posted: Mar 16, 2013


johnd on March 16, 2013

If I try to add another product with that same SKU it bitches and won't let me add it. I get this error:

This SKU is already in use and must be unique. Please supply another value.

johnd on March 16, 2013

I also broke things down and tried to import some nodes with SKU only. This did not work. I got the same result - those nodes showed up in the database but not in the product list.

johnd on March 16, 2013

I take that back again - it does add the nodes. They were just down at the bottom of the page because they weren't assigned a node type. I'm wondering if there is a way for me to explicity access the products by typing something in the address bar?

johnd on March 16, 2013

I tested this on another site on my platform using the shoppica theme and was able to import products and they showed up in my products list. Any ideas here?