Vote up!
Vote down!

I am completely new to this and need to increase my memory limit can you help me?


I am a complete newbie to this so please bare with me. I am trying to install commerce kickstarter with mamp and keep getting the php memory limit error when I attempt the install. I have tried several times to increase the memory limit with the aid of the Q&A on this site and I have also searched through google and youtube but still I have not had any luck. I have managed to locate the php.ini file in terminal and even edit it but I cannot seem to save it, there is no error message just nothing happens when I use the control - o control - x commands. I am not very familiar with terminal either.

If someone could please give me the steps to performing a memory limit change in plain english, including saving and exiting this should set me on my way.

Thank you in advance

Hopefully I will pick this all up quickly so I can return the favour one day


Asked by: ajag5
on January 22, 2013


4 Answers

Vote up!
Vote down!

you can't edit it because you don't have permissions. you need to be root to edit this file. if you are root and still can't edit it, you need to temporarily change permissions, edit the file and revert the permissions.

Answer by: drupalability
Posted: Feb 1, 2013
Vote up!
Vote down!

You will need to make 2 changes

1. Go to your settings.php located at sites/default/settings.php and add a line

2. Go to your PHP.INI file and increase the memory -
Search for memory_limit and increase the memory there.

This should do the trick.

Answer by: vishy_singhal
Posted: Jan 24, 2013


Thanks for the help Vishy_singhal I located the settings file and added the line you suggested, however while I can locate the php.ini file and I can find the memory_limit line I cannot edit it. I have tried to edit this memory_limit line a number of different ways without any luck. I can only view it not edit it. Any suggestions?

- ajag5 on January 30, 2013

Thanks for your help vishy_singhal I took the first step but was unable to do complete the second step. Could you please tell me how to edit the php.ini file, I don't seem to be able to change anything. As I said I am very new to this so if you could give me some basic advice as to how to edit this file it would be much appreciated.

- ajag5 on January 31, 2013
Vote up!
Vote down!

Did you edit php.ini with root privileges? You might have to do something like:

sudo nano php.ini

Answer by: jstrosch
Posted: Jan 22, 2013


Thanks for your help jstrosch but unfortunately using sudo has not fixed the problem. I feel like I am very close but can't quite get there. I have found the file after using the sudo command and entering my password but once I edit the memory limit to 128 I am unsure where to go from there. I have been advised to use the control o function followed by the control x function to save and exit but control o seems to do nothing and control x provides me with a series of functions to choose from at the bottom of the screen but none of them seem to have the desired effect resulting in me eventually closing the window and losing any changes made.

It seems odd that given that almost everyone installing the commerce kickstarter would need to increase this memory limit that there is not a step by step instruction to do so. The instructions provided on the Drupal website only told me how to locate the file and even that wasn't very clear. If anyone has overcome this problem please let me know.

Thanks again

- ajag5 on January 22, 2013