Vote up!
Vote down!

403 Error - Access denied

Right, basically I'm trying to add the ability for authorised users (Sellers) to add their own products to the shop. I have allowed all the permissions I think I needed to and have added an add button to the menu.

Logged in as a test account with (seller) role, and tried adding a product. The page for adding products (admin/commerce/products/add/product) loads and have filled the details in as you do, uploaded the picture and click "Save Product" how ever once clicked I get a page showing.

Home » 403 error
Status message Product saved.

Access denied

Although it does say product saved, when I then try and find the product it does not exist. I have checked the database and there is no trace.
I have tried doing this using my Admin account and it worked perfectly fine.
Any suggestions much appreciated, I'm sure I have over looked something simple but I just can't seem to see it.

Sorry if this has been asked and answered before, search for it but could not find the answer.

Thank you, Doug.


Turns out they are being added to my Database I was just looking in the wrong place. Just need to now figure out why they are displayed when an Admin add's products but not if a Seller does.

Asked by: doughayward0
on October 25, 2012

1 Answer

Vote up!
Vote down!

"Recipe" questions are better off in the discussion arena.


Josh Miller
Answer by: Josh Miller
Posted: Jan 11, 2013