Vote up!
Vote down!

Cannot install Commerce contrib modules

Hello everyone,

for some reason I can't install commerce contrib modules. But instead of giving me an error, it simply reloads the Module overview without doing anything. Has anyone encountered this problem before?

My local installation works just fine, but my new web-installation won't let me install any commerce contrib modules.

I tried it with commerce_paypal and commerce_checkout_progress.

Please help!

Asked by: Gentaro
on November 11, 2015

5 Answers

Vote up!
Vote down!

same problem here

Not able to enable Commerce License 7.x-1.3 or 7.x-1.x-dev
Tried several times each time on clean Drupal install.

Apache, MySQL, PHP 5.6
clean standard install of Drupal 7.41

All dependent modules are awailable
Enabled all commerce modules with success
Commerce 7.x-1.11

All dependent modules are awailable
Trying to enable in admin/modules
Commerce License 7.x-1.3
No errormessage, not installed, shows uninstalled in admin/modules
No loginfo.
No changes in DB system table.

I have no problem enabling other modules.
Other modules uses same environment and Drupal version so how can it be
environment problem or Drupal problem?

Answer by: cord1
Posted: Nov 12, 2015
Vote up!
Vote down!

Having the same problem here…

On our development/test installation I came to notice that many (not all) of my contrib commerce modules were put into the disabled state and on the Uninstall screen. Trying to re-enable them was unsuccessful. I then uninstalled all of them and when I went to install them from scratch, I'm just returned to the module page with no errors or notifications of any kind and nothing in the logs either.

I'm currently testing and trying to find if there's a difference between the modules that will install and the ones that won't.


•• matt

Matt Lurken Tvrdik
Posted: Nov 17, 2015
Vote up!
Vote down!

Same problem....

cannot install commerce contrib and shipping modules. No error logged.

occurs after core Drupal 7.41 installation and Commerce module.
occurs installing the latest distribution
occurs if i move a full working shop to a now hosting

Answer by: dirk
Posted: Dec 20, 2015
Vote up!
Vote down!

This is not a direct problem with Commerce:

I had the same problem after moving the shop to a new hosting.
Even changing the module status to "1" directly in the database didn't help.

In the moment the only way to solve the problem seems to remove all round brackets in the package name (see linked page of @dirk above).

I made a small custom module to alter the package names:

function MYMODULE_system_info_alter(&$info, $file, $type) {
  if($type == 'module') {
    if ( strpos( $file->info['package'], '(' ) !== false ){
      $file->info['package'] = str_replace('(','',$file->info['package']);
      $file->info['package'] = str_replace(')','',$file->info['package']);
Answer by: tfranz
Posted: Mar 29, 2016