Vote up!
Vote down!

Stuck with reading a feed into product_display

I created a shop and read lots of products into the database.

I used commerce feeds module, which worked greate, after I added feeds_tamper, to manage the prices comming from the external system.

Now I am stuck with the second step.

It gives me an error, when I try reading in records with images.

I created a folder called produktbilder under the files folder, and gave it the complete rights set (777).

I assigned the ownership to root:apache.

But still I receive this message:

File temporary://fileY7UVAP could not be copied, because the destination directory public://produktbilderpublic://produktbilder is not configured correctly.

The directory string in this message confuses me.

Anyway, there are no records created.

If I create a record manualy, it works perfect. I can upload a picture with no problem, or create a record without one.

Somehow it has to do with the rights of the cron job user.

And this listed folder name is realy confusing.

I need a hint, how and where to look after this problem.

There are only 17000 Records waiting to be imported ;-)

Asked by: ronald
on July 31, 2012

1 Answer

Vote up!
Vote down!

1. Check your reports to make sure your sites/default/files folder is writable.

2. If it is writable, check to see if the files you are "importing" point to an "external" url ... I've only had luck with pointing to external images, not sure what the format is for internal urls, but I'd imagine it's not a simple file structure from root

3. If that still doesn't work, look for feeds help in their issue que.

Josh Miller
Answer by: Josh Miller
Posted: Sep 5, 2012