teaser ok but full product broken

Hi I am new to Drupal and Commerce.

I have created a product and a product type is the store.
All fields in the product type are set to visible on all views.
I have created a content type that has a product reference.
I created a node that links to my product.

The teaser in the home page the all product fields show up normally.

However, when I click "Read more" I only get the description and a link to the "Product", which points to the product admin page, and the fields don't appear.

How can I setup my content type so that the "Read more" page shows all the fields of the linked procuct?

Posted: Jun 6, 2011


neardark on June 6, 2011

Vagalakas -

See: http://www.drupalcommerce.org/node/517

This post might help - looks like your Read More is linking to the product administration, rather than the content node itself. Maybe check the following:

  • Your Product Type should have lots of fields, including Title, Price, Sku, Status, and additional fields like Photo, etc. Add at least one product for testing.
  • Your Product Display should be a (Node) Content Type that has at least a Title and a Product Reference field. I usually add the body field to the product display as a description too. Populate at least one product display for testing.
  • Use the Manage Fields/Manage Display Tabs on the Product Type to adjust order, labels, visibility for nodes/teasers. Tweaking to the Product Display content type might also be useful.
  • Make certain on your home page that only product displays are showing up - If you're displaying teasers, the Read More links should link through to the full Product Display content.


vagalakas on June 7, 2011

Thanks for the help John.

I fixed the problem. Here is what I did, in case anybody else has the same problem:

1. From admin/commerce/products/types/(my product)/display opened "Custom Display Settings" and checked "Node:Full Content". A new tab appears in the top of the page called "Node: Full Content".

2. Clicked on the new tab, and made all fields visible and then saved.

3. From /admin/structure/types/manage/(my display content type)/display opened "Custom Display Sttings" and checked "Full Content".

4. From admin/structure/types/manage/(my display content type)/display/full, I customized the settings

5. THIS IS VERY IMPORTANT: THE PRODUCT REFERENCE FIELD MUST HAVE BOTH LABEL AND FORMAT HIDDEN (This is what I missed the first time). Otherwise you just get a link to the admin page of the product, and all fields remain hidden.

PS. Thanx for the link. Views seem really cool